Account Analysis Report

This guide will cover:

 

Information

Pre-built reports by division are run after each month close by Financial Affairs. To access these pre-built reports instead of running the report yourself, you can access the Account Analysis folder within the UW Shotgun directory by clicking this link: \\warehouse\shotgun$\Financial_Management_Reports\ (If clicking the link does not work, copy the link into your computer's search.)

Note: If you are working off-campus, you must be logged in to the VPN (Pulse Secure) to be able to view the UW Shotgun directory.

Additionally, users can run this report themselves as well for any period or date range for any segment of a chart string. The steps outlined below are instructions on how to pull the data from the General Ledger via the Account Analysis Report and pull the Budget Details by Period report. Using these two files, the macro excel workbook attached to the knowledge base is used to combine the files into pivot tables and format the report.

 

This guide has three parts. Steps 1-5 outline running the Account Analysis Report to show only actuals/encumbrances.  If you would like to also view budgeted amounts (including remaining budget authority), continue onto the remaining steps.  At the end is an addendum for advanced features and information to aid in reading the completed report.

 

Step One

Upon accessing the WyoCloud homepage, navigate to Scheduled Processes

  • Click on the Navigator (three horizontal lines) in the upper left corner of the homepage.

  • First click on Tools to expand (you may need to scroll within the navigator), then click Scheduled Processes.

  • The Scheduled Processes page is displayed.

 

Step Two

Access the Account Analysis Report

  • Click on Schedule New Process.

  • In the Schedule New Process pop up window, click on the arrow to the right of Name.

  • Click Search.

 

Note: Although you will likely see a number of options within Scheduled Processes, the Account Analysis is the only process campus users are able to run.

 

  • Type account into the name field then click search.

  • Highlight Account Analysis and click OK.

  • Click OK in the Schedule New Process window.

 

Step Three

Schedule the account analysis report. In this step you will specify the parameters you’d like to run the report by

  • In the pop up window, complete the following fields:

    • Subledger dropdown: blank (leaving this field blank pulls all transactions from the subledger)

    • From Accounting Period: Select the first period you wish to run the period from (format is Jul-21 for July in FY21)

    • To Accounting Period: Most recent closed accounting period (format is Jul-21 for July in FY21)

    • Balance Type: Actual OR leave blank.  If left blank, both actuals and encumbrances will be included.

  • In the same window, click on the blue filter icon next to Account Filter Conditions Defined.

  • In the new pop up window, select Add Fields then Organization.
    • Although you can filter by additional fields it is recommended to just filter your Organization or range of Organizations at this step.  This will pull in all transactions affecting your organization.  Please note that the other chart of accounts segments will also pull in when you run this report using this filter. 
    • Note: At least one filter must be entered.

  • Complete the fields per the Organization data you’d like returned. Click OK.

  • Click Advanced.

  • Click Output, then the plus sign.

  • In the Format drop down, CSV must be selected.
  • Click Submit.

  • In the confirmation window, click OK.

 

Step Four

Retrieve and download the report

  • From the Scheduled Processes window, click on the blue refresh button to check to see if the report has completed running.  You may have to click the refresh multiple times.

  • Once the Account Analysis Report appears with a Status of Succeeded, it has completed running.

  • Double click on Account Analysis Report to open additional details at the bottom of the screen.

  • Scroll down to the Output area on the lower half of the screen, then click on the Output Name.

  • If an excel pop-up window appears, you can select Open with or Save File. It is recommended to just save the file. Click Ok.

 

Note: If Microsoft Excel doesn’t show as an option in the Open with field, you will need to change your computer’s default settings for opening .csv files. For details on doing this see this Knowledge Base article.

 

  • Save the file to your desktop. Be sure to select CSV (Comma delimited) (*.csv) from the Save as type dropdown.
    • Note: This is just a temporary save and can be discarded after the macro is run in step five.

  • Be sure the file is not opened prior to proceeding to step five.

 

If you would like to include both actual/encumbrance AND budget data, skip to Step Six. If you would like to run the Account Analysis including ONLY actual and encumbrance data, continue to Step Five.

 

Step Five

In this step you will download and run the Account Analysis Pivot Macro to properly format the report for use.

  • Download the Account Analysis Pivot Macro located in the files section on the right side of this webpage

    • As a best practice, always download the macro file directly from the Knowledge Base each time you use it to ensure you are utilizing the most current version.

  • Upon opening the Account Analysis Pivot Macro, you will first need to select Enable Content in the yellow ribbon at the top.  Then click the grey Generate Pivot Account Analysis Report button (located in the Process tab).

  • In the Instructions pop up window, click OK.

  • Navigate to where you saved the exported Account Analysis Report from WyoCloud Financial Management Scheduled Processes on your desktop (obtained in step 1-4). Select it then click Open. (Note: It will likely take several moments for the macro to process.)

  • Once complete, the report will look similar to this:

  • Use Save As to rename and save the report to your desired location for future reference.

 

If you would like only actuals and encumbrances (not budget information) included in your report, you may stop here.  Continue to Step 6 to add budget information to the report.

 

For tips on reading the Account Analysis Report, see the Appendix: Reading the Report.

 

Step Six

Run Budget Details by Period report by navigating to the Transactional Reporting Table of Contents

  • Select the Budget Details by Period, under the "Budget and General Ledger" heading.
  • Select the same Organization which the Account Analysis was ran and then select the budget year you wish to include. Click Apply.

  • The Budget Details By Period Report will automatically exported to excel and is displayed here.

  • To add the report to the Account Analysis Pivot Macro, click File then Save As
  • Save the file to your desktop and close the file.
    • Note: This is just a temporary save and can be discarded after it is added to macro in step seven.
  • Back in the Account Analysis Workbook on the Process Tab, click the grey Generate Pivot Budget Details by Period Report button.

  • In the Instructions pop-up window, click OK.

  • Navigate to where you saved the exported Budget Details by Period Report from the Transactional Reporting Table of Contents. Select the file then click Open.
  • The report may take a few moments to run, but will open the Budget Summary tab in the excel workbook once completed.

 

This concludes running the reports yourself. Continue on to read a few advance features, tips, and information about reading the report.

 


Consolidated Report Running

The following steps outline how to run both the Account Analysis (actuals and encumbrances) and Budget Details by Period Report into the macro at the same time to view both data sets side by side.*  

*Note: If you would only like to review actual/encumbrance data, use Step Five.

  • Download the Account Analysis Pivot Macro located in the files section on the right side of this webpage (link).

    • As a best practice, always download the macro file directly from the Knowledge Base each time you use it to ensure you are utilizing the most current version.

  • Upon opening the Account Analysis Pivot Macro, you will first need to select Enable Content in the yellow ribbon at the top. 
  • Then click the grey Run All button below the two brown boxes (located in the Process tab).

  • You will be instructed to first locate the Account Analysis report you exported in Steps 1-4, click OK.

  • Navigate to where you saved the exported Account Analysis report. Select it then click Open

  • The macro will likely take several moments to process prior to showing a second instruction window. This window will instruct you to select the exported Budget by Account report.

  • Navigate to where you saved the exported Budget Details by Period Report from WyoCloud Financial Management on your desktop (obtained in step 6). Select it then click Open.

  • Once complete, the report will automatically open the BudgetSummary tab. This tab allows for viewing budget and actual data side-by-side. 

  • You may also review only actual/encumbrance information using the AASummary tab.

 

Note: For tips Advanced Features of the Macro Pivot, see the appendix below.

 


Appendix: Advanced Features of the Macro Pivot

Tips and advanced features of the Account Analysis Pivot Macro

 

This section covers features available within Account Analysis Pivot Macro.  In order to utilize these features, you must first run the macro per the directions outlined in the Running the Account Analysis guide.  Features which require budget information to be included when running the report are noted below.

 

Expanding details of pivot tables

There are two pivot tables included within the Account Analysis Report, one located on the AASummary tab, and one on the BudgetSummary tab (if budget information is included when running the report). From either tab, simply double click on any numerical value to open a new tab with the full details.

  • The full details of what makes up that number will open into a new tab. See Appendix: Column Definitions for details.

 

Customizing Details Shown in Expanded View

By default all available data for transactions is displayed when expanding transactional details by double clicking on a numerical value within a pivot table.  However, you may not find all columns helpful for your needs.  For example, you may only want to show the combined charge string of the transaction, not each segment displayed in its own column.  You may adjust the columns displayed by using the Data Select tab.

  • The Data Select tab includes all column headers available.  To indicate whether you’d like a given column included in your expanded transactional details, click on the cell under the column header (in row 5).  Use the drop down arrow to toggle between 1 and 0.  Selecting 1 indicates that you would like to view this column when viewing expanded details.  0 indicates you’d like this column hidden.  See Appendix: Column Definitions to assist in identifying which columns to include.

  • After selecting which columns you would like included, return to a tab which includes a pivot table (AASummary or BudgetSummary).  Select the numerical field you’d like expanded details on, then select Show Selected Details at the top of the page.

  • This opens the transactional details in a new tab, only including the data columns you indicated on the Data Select tab.

 

Adding Data Not Currently in WyoCloud

The Account Analysis report includes the most complete and up to date transactional data available within WyoCloud.  However there maybe circumstances where you are aware of transactions, such as IDT journal entries, that have not yet been posted in the system.  You may use the Add Data feature to review your accounts with these transactions taken into account.

  • From the Process tab, select Add Data.

  • In the Add Data pop up window, enter all information for the transaction you’d like to add to the report.  When complete, click Insert Line.

  • This adds the line to the full report and will be included within the details on all tabs.  The Add Data window remains open to add additional lines. The lines will be shown as encumbrances Click Exit when you are done adding lines.

 

Note: For tips on reading the completed report, see the appendix below.

 

Appendix: Reading the Report: AASummary Tab

After running the macro, the report opens to the AASummary tab

  • From this tab you can filter to specific segments of the chart string by using the filters at the top:
  • From the AASummary tab, you can also drill in to see the details of specific amounts by double clicking a natural account name or clicking the + to expand rows in column D, Natural Account-Desc.

Please note a few items:

  • Balance sheet items (natural accounts under 39999) are NOT filtered out of the totals and will be displayed on this tab.
  • Fund Source 000000, which is only used internally by Accounting, is NOT filtered out on this tab, but can be ignored for your viewing.

  • You can expand the details of all transactions included within a specific amount by double clicking an amount within the Accounted DR, Accounted CR or Total columns.

  • The full details of what makes up that number will open into a new tab. See Appendix: Column Definitions for details.

 

Note: For better understanding on how to utilize pivot tables such as this one, UWIT offers useful trainings.  To see offerings visit the UWIT Catalog on WyoLearn. For Excel/Pivot table questions you may also email computer.training@uwyo.edu.

 

Reading the Report: BudgetSummary Tab

Similar to the AASummary tab, you can click on any number in columns: Accounted DR, Accounted CR Budget or Variance and the full details of what makes up that number will open into a new tab. The % Remaining column shows as a percentage how much of the budget has been used. See the appendix for column definitions.

  • A summary of expenditure totals, revenue, and budget as well as remaining spending authority are included in the upper right corner. 

Please note a few items:

  • Balance sheet items (natural accounts under 39999) are filtered out of the totals and only displays those natural accounts that can have a budget to them.
  • Fund Source 000000, which is only used internally by Accounting, is also filtered out on this tab so it doesn’t impact the view of the spending authority for your division/department. 

 

Appendix: Column Definitions

After clicking on a value to expand full details or the Combined Data tab, the following columns are included:

Column Name

Data Included

P_Period_From

Reflects the starting month of the report (as input when scheduled).

P_Period_To

Reflects the ending month of the report (as input when scheduled).

Balance_Type

Will show if transaction represents an actual or encumbrance (if encumbrances were included when running report)

Accounting_Code_Combination

Full accounting chart string.

Code_Combination_Description

Written version of the accounting chart string.

Period_Year

Year of the period.

Period_Number

Corresponds with the month of the fiscal year (i.e. July = 1, August = 2).

Period_Name

Name of the period (month).

Period_Start_Date

First day of the period.

Period_End_Date

Last day of the period.

Balancing_Segment

Entity

Natural_Account_Segment

Natural Account

Cost_Center_Segment

Organization

Balancing_Segment_Desc

Written version of Entity.

Natural_Account_Segment_Desc

Written version of Natural Account.

EnTITY

Entity

Natural account

Natural Account

fund class

Fund Class

fund source

Fund Source

Expense class

Expense Class

program

Program

activity

Activity

future

Future

GL_Date

The date the transaction was posted to the General Ledger (GL).

Created_By

Who entered into the GL. Note if this column shows serviceuw.integration this is a feeder file such as Banner, Telecom, Copier, Postal or Payroll.

Creation_Date

When the transaction was initially entered into the system.

Last_Update_Date

When the transaction was last updated.

Header_ID

This is a system generated number.

Header_Description

Description which was entered at the header level when the user entered the transaction.  The exception is those that say Journal Import indicate integrations or journal entries.

JE_Category_Name

Type of entry the transaction was given when it was entered.

JE_Source_Name

The source of the journal entry.

GL_Batch_Name

This is the name of the batch in the GL which can be utilized to search for more details within the system.

Posted_Date

The date the transaction first occurred within the system.

GL_JE_Name

This is the kind of journal entry.

GL_Line_Number

Journal line number.

Line_Number

The line number of the journal entry.

Orig_Line_Number

Original journal or subledger line number.

Line_Description

Description which was entered at the line level when the user entered the transaction.

GL_Transfer_Date

Date when the journal entry is transferred to the GL.

Completed_Date

Subledger journal entry completion date.

Transaction_Number

The number of the transaction.

Application_Name

Indicates the application in the system which was used to process the transaction.  (i.e., Payables: Invoices, Purchasing: Reqs and POs, Project Costing: PPM (grants).

Event_ID

This is system generated information.

Event_Date

This is system generated information.

Event_Class_Name

The accounting event that originated the journal entry (i.e., credit memo, period end accrual).

Event_Type_Name

The action taken relating to the accounting event that originated the journal entry (i.e. credit memo validated, invoice cancelled, invoice validated).

Accounting_Class_Name

Accounting class assigned to the subledger journal entry line.

Party_Number

Supplier Number.

Party_Name

Supplier Name.

Party_Site_Number

Number assigned to the supplier’s address.

Party_Site_Name

Supplier’s address. Note: this appears as Order / Remit for transactions paid electronically.

INCLUDE_ACCT_WITH_NO_ACT

This are the filter options you selected when you scheduled the report.

BALANCE_TYPE_DSP

This are the filter options you selected when you scheduled the report.

FILTER_CONDITIONS_ATT

This are the filter options you selected when you scheduled the report.

FILTER_CONDITIONS_OPT

This are the filter options you selected when you scheduled the report

Accounted_DR

A debit posted to the General Ledger (GL)

Accounted_CR

A credit posted to the General Ledger (GL)

COST_CENTER_DESC

Written Organization name

ORG

Numerical Organization

Balance

Balance of Debits minus Credits

 

Was this helpful?
0 reviews

Details

Article ID: 47811
Created
Mon 2/5/18 3:40 PM
Modified
Fri 5/13/22 2:23 PM